Jump to content

Ejecución de comandos devuelve error en chat


Cafetera
 Share

Recommended Posts

 

Descripción del error:

Si ejecutamos un comando o una macro que lleve un /run, /script, etc... devuelve el siguiente mensaje de error: "No hay ningún jugador con el nombre Libraries."

El mensaje de error que devuelve es como si quisiera enviar un susurro pero no encuentra al jugador Libraries.

 

Descripción de cómo debería funcionar:

No debería aparecer ningún error.

 

Formas de reproducir el error:

- Realizar un simple "/reload". Al cargar la UI en el chat aparece el error.

- Usar Macro para desbuguear Recount y otros addons, ejemplo:

/run local f = CreateFrame("frame",nil, UIParent); f:SetScript("OnUpdate", CombatLogClearEntries);

 

Podeis escribirlo en el chat sin necesidad de crear una macro. Esto antes no ocurría.

Muchos addons llevan comando de este tipo y spamearía el chat de los jugadores con este mensaje.

 

 

 

Pruebas:

 

aQc8kAx.png

 

 

 

Saludos.

Link to comment
Share on other sites

  • Administrador

No me es posible replicar el problema.

He podido usar /run and /script en 2 personajes (cuentas diferentes) e incluso he probado los que has mencionado.

 

O bien necesitas si o si borrar cache y WTF, o bien un addon que te está bloqueando.

 

Por favor haz pruebas luego de borrar cache y WTF, sin addons.

También indica qué idioma de cliente estás usando por favor, para probar con el mismo.

Link to comment
Share on other sites

No me es posible replicar el problema.

He podido usar /run and /script en 2 personajes (cuentas diferentes) e incluso he probado los que has mencionado.

 

O bien necesitas si o si borrar cache y WTF, o bien un addon que te está bloqueando.

 

Por favor haz pruebas luego de borrar cache y WTF, sin addons.

También indica qué idioma de cliente estás usando por favor, para probar con el mismo.

 

Cliente idioma esES.

Comprobado en otro cliente limpio, sin addons y WTF no ocurre. También esES.

 

Saludos.

Link to comment
Share on other sites

  • Administrador

Yo he probado esES y siempre suelo borrar Cache y WTF.

Por favor, antes de reportar cualquier error, prueben borrar Cache y WTF.

 

Si no los quieren borrar, muevan dichas carpetas temporalmente a otro directorio y prueben.

Quiero recalcarles que todo el código del servidor ha cambiado y pueden ocurrir problemas al colisionar el código nuevo con la información en cache que guarda el cliente.

Link to comment
Share on other sites

Yo he probado esES y siempre suelo borrar Cache y WTF.

Por favor, antes de reportar cualquier error, prueben borrar Cache y WTF.

 

Si no los quieren borrar, muevan dichas carpetas temporalmente a otro directorio y prueben.

Quiero recalcarles que todo el código del servidor ha cambiado y pueden ocurrir problemas al colisionar el código nuevo con la información en cache que guarda el cliente.

 

Encontrado el error.

En mi caso corresponde a un addon que trackea los trinkets de las unidades player, party1-2 y arena1-3. Desactivandolo se solventa. No tiene que ver con la carpeta Cache o WTF.

No ocurría con el antiguo Core. Como es un addon bastante específico no creo que otros tengan el mismo problema, aunque les podría ocurrir con otro tipo de addons similares.

 

 

Link to comment
Share on other sites

  • Administrador

Gracias por la información añadida.

 

¿Podrías indicarme el nombre del addon?

Veremos si podemos hacer algún cambio del lado del servidor para que el addon siga funcionando como antes.

Link to comment
Share on other sites

 Share

×
×
  • Create New...